libidn.so.11 dependency

Fehlerberichte, Hilfe und Anregungen zu TextMaker 2018 für Linux

Moderator: SoftMaker Team

Antworten
flockmock
Beiträge: 2
Registriert: 28.05.2017 21:34:52

libidn.so.11 dependency

Beitrag von flockmock » 25.06.2018 16:55:32

Hallo,
wenn man die neuesten Version von libidn installiert hat (libidn-1.35), dann wird das file libidn.so.11 nicht mehr angelegt (neue Version: libidn.so.12) und Textmaker stürzt ab, bzw. lässt sich nicht mehr starten, mit folgender Fehlermeldung:

/opt/office2018/textmaker: error while loading shared libraries: libidn.so.11: cannot open shared object file: No such file or directory

Abhilfe schafft ein manueller link im lib64 Verzeichnis:
ln -s libidn.so.12 libidn.so.11

damit funktionierts wieder, aber das kann nur eine temporäre Lösung sein... bitte an die Entwickler weiterleiten.
Danke, mfG

sven-l
SoftMaker Team
SoftMaker Team
Beiträge: 12469
Registriert: 09.04.2008 09:50:06
Wohnort: Nürnberg
Kontaktdaten:

Re: libidn.so.11 dependency

Beitrag von sven-l » 04.07.2018 13:18:53

Welche Linux-Distribution genau verwenden Sie, und wird dort die libidn in der Version 12 standardmäßig mitgeliefert?
Sven Leßmann
SoftMaker Software GmbH

flockmock
Beiträge: 2
Registriert: 28.05.2017 21:34:52

Re: libidn.so.11 dependency

Beitrag von flockmock » 12.07.2018 22:42:11

Gentoo unstable, aber früher oder später werden wohl auch die klassischen Distributionen updaten ;)
LG

sven-l
SoftMaker Team
SoftMaker Team
Beiträge: 12469
Registriert: 09.04.2008 09:50:06
Wohnort: Nürnberg
Kontaktdaten:

Re: libidn.so.11 dependency

Beitrag von sven-l » 16.07.2018 14:20:53

Ich habe das Problem gemeldet. Danke für den Hinweis!
Sven Leßmann
SoftMaker Software GmbH

sven-l
SoftMaker Team
SoftMaker Team
Beiträge: 12469
Registriert: 09.04.2008 09:50:06
Wohnort: Nürnberg
Kontaktdaten:

Re: libidn.so.11 dependency

Beitrag von sven-l » 18.07.2018 17:30:39

SoftMaker Office 2018 benötigt stets libidn11 als Abhängigkeit. Dieses wird automatisch installiert, wenn Sie Office 2018 über das deb-Paket installieren.
Sven Leßmann
SoftMaker Software GmbH

Antworten

Zurück zu „TextMaker 2018 für Linux“