Problem mit UpdatePack 933 unter Linux Mint 19

Fragen und Antworten zu SoftMaker Office 2018 für Linux allgemein. Für alles andere bitte die programmspezifischen Foren benutzen.
Benutzeravatar
ts-soft
SoftMaker Volunteers
SoftMaker Volunteers
Beiträge: 460
Registriert: 12.11.2011 19:29:30
Wohnort: Berlin

Problem mit UpdatePack 933 unter Linux Mint 19

Beitrag von ts-soft » 22.06.2018 00:27:03

Das UpdatePack erfordert curl3, aber curl4 ist für VirtualBox erforderlich. Da ich mich nicht entscheiden möchte, zwischen dem Office Paket und VirtualBox, wäre es wohl erforderlich, das Setup anzupassen! Da waren aber noch mehr Pakete, die erst deinstalliert werden müssten, damit das Update eingespielt wird.
Weder das autom. Einspielen, noch ein manuelles Setup will helfen!
Windows 10 Pro (x64), 1909 18363 | Linux Mint 19.3 (x64)

Benutzeravatar
ts-soft
SoftMaker Volunteers
SoftMaker Volunteers
Beiträge: 460
Registriert: 12.11.2011 19:29:30
Wohnort: Berlin

Re: Problem mit UpdatePack 933 unter Linux Mint 19

Beitrag von ts-soft » 22.06.2018 00:48:43

Hab jetzt mit Timeshift erstmal alles zurück gesetzt und einen Schnappschuss von Gdebi gemacht:
Auswahl_001.png
Auswahl_001.png (215.01 KiB) 1602 mal betrachtet
Windows 10 Pro (x64), 1909 18363 | Linux Mint 19.3 (x64)

sven-l
SoftMaker Team
SoftMaker Team
Beiträge: 12991
Registriert: 09.04.2008 09:50:06
Wohnort: Nürnberg
Kontaktdaten:

Re: Problem mit UpdatePack 933 unter Linux Mint 19

Beitrag von sven-l » 22.06.2018 09:07:04

Das Problem habe ich mit hoher Priorität an die Entwickler weitergeleitet.
Sven Leßmann
SoftMaker Software GmbH

Benutzeravatar
ts-soft
SoftMaker Volunteers
SoftMaker Volunteers
Beiträge: 460
Registriert: 12.11.2011 19:29:30
Wohnort: Berlin

Re: Problem mit UpdatePack 933 unter Linux Mint 19

Beitrag von ts-soft » 22.06.2018 09:15:19

Danke dafür!
Windows 10 Pro (x64), 1909 18363 | Linux Mint 19.3 (x64)

Kuno
SoftMaker Volunteers
SoftMaker Volunteers
Beiträge: 2838
Registriert: 02.03.2004 12:31:01
Wohnort: Osnabrück

Re: Problem mit UpdatePack 933 unter Linux Mint 19

Beitrag von Kuno » 22.06.2018 09:47:58

Ob da zwischen Ubuntu/Mint und Debian was unterschiedlich ist... ?
Ich hab hier unter Debian Sid/Unstable auch nur libcurl3 installiert, aber VirtualBox 5.2 läuft hier problemlos.
Gimp ist auch bei 2.10. Ich schau gleich mal im Büro nach, wie es mit Debian Stretch aussieht...

EDIT: Virtualbox willl unter Ubuntu/Mint seit Version 18 tatsächlich libcurl4 haben. Dann müsste das Problem auch bei anderen Usern auftauchen... :(
Systeme
Home: Core2Duo T9600 @ 2.80GHz 4Gb Ram - Intel GM45 - Mesa 19.3.3-1
Debian Sid/Unstable Openbox - Linux 5.7.0-rc5-amd64
--------------------------------------------------------
Office: Core2Duo P8700 @ 2.53GHz 4Gb Ram - Intel GM45 - Mesa 18.3.6-2+deb10u1
Debian Buster Openbox - Linux 5.7.0-rc5-amd64

martin-k
SoftMaker Team
SoftMaker Team
Beiträge: 5768
Registriert: 03.12.2003 14:32:06
Kontaktdaten:

Re: Problem mit UpdatePack 933 unter Linux Mint 19

Beitrag von martin-k » 22.06.2018 10:31:27

Das ist ziemlicher Mist, den Ubuntu da produziert hat und der viele Linux-Pakete betrifft.

Siehe auch: https://bugs.launchpad.net/ubuntu/+sour ... ug/1754686
Martin Kotulla
SoftMaker Software GmbH

Kuno
SoftMaker Volunteers
SoftMaker Volunteers
Beiträge: 2838
Registriert: 02.03.2004 12:31:01
Wohnort: Osnabrück

Re: Problem mit UpdatePack 933 unter Linux Mint 19

Beitrag von Kuno » 22.06.2018 10:43:22

martin-k hat geschrieben:
22.06.2018 10:31:27
Das ist ziemlicher Mist, den Ubuntu da produziert hat und der viele Linux-Pakete betrifft.

Siehe auch: https://bugs.launchpad.net/ubuntu/+sour ... ug/1754686
Würde SMO denn funktionieren, wenn im control-file libcurl von 3 auf 4 gesetzt wird?
Systeme
Home: Core2Duo T9600 @ 2.80GHz 4Gb Ram - Intel GM45 - Mesa 19.3.3-1
Debian Sid/Unstable Openbox - Linux 5.7.0-rc5-amd64
--------------------------------------------------------
Office: Core2Duo P8700 @ 2.53GHz 4Gb Ram - Intel GM45 - Mesa 18.3.6-2+deb10u1
Debian Buster Openbox - Linux 5.7.0-rc5-amd64

martin-k
SoftMaker Team
SoftMaker Team
Beiträge: 5768
Registriert: 03.12.2003 14:32:06
Kontaktdaten:

Re: Problem mit UpdatePack 933 unter Linux Mint 19

Beitrag von martin-k » 22.06.2018 10:44:22

Ja, das sollte funktionieren. Bitte mal ausprobieren und melden, ob es bei Ihrem Linux so funktioniert.
Martin Kotulla
SoftMaker Software GmbH

Kuno
SoftMaker Volunteers
SoftMaker Volunteers
Beiträge: 2838
Registriert: 02.03.2004 12:31:01
Wohnort: Osnabrück

Re: Problem mit UpdatePack 933 unter Linux Mint 19

Beitrag von Kuno » 22.06.2018 11:09:26

martin-k hat geschrieben:
22.06.2018 10:44:22
Ja, das sollte funktionieren. Bitte mal ausprobieren und melden, ob es bei Ihrem Linux so funktioniert.
Das müsste Kollege TS-Soft machen, ich bin unter Debian noch bei curl3...

Aber ich häng hier mal ein Script an:
debedit.txt
(1.18 KiB) 29-mal heruntergeladen
".txt" nach runterladen löschen und debedit unter z.B. /home/user/bin speichern. Im Script oben den gewünschten Editor eintragen, ist bei mir auf geany eingestellt. Ich hab mir für debedit noch eine passend desktop-Datei angelegt. Dann lassen sich die debs bequem per Rechtsklick mit dem Script öffnen.
debeditdesktop.txt
(321 Bytes) 34-mal heruntergeladen
Umbenennen in debedit.desktop und nach /home/user/.local/share/applications schieben.

EDIT: Das Script scheint mit dem SMO-Paket wegen Schreibschutz nicht zu funktionieren... :evil:
Systeme
Home: Core2Duo T9600 @ 2.80GHz 4Gb Ram - Intel GM45 - Mesa 19.3.3-1
Debian Sid/Unstable Openbox - Linux 5.7.0-rc5-amd64
--------------------------------------------------------
Office: Core2Duo P8700 @ 2.53GHz 4Gb Ram - Intel GM45 - Mesa 18.3.6-2+deb10u1
Debian Buster Openbox - Linux 5.7.0-rc5-amd64

Benutzeravatar
ts-soft
SoftMaker Volunteers
SoftMaker Volunteers
Beiträge: 460
Registriert: 12.11.2011 19:29:30
Wohnort: Berlin

Re: Problem mit UpdatePack 933 unter Linux Mint 19

Beitrag von ts-soft » 22.06.2018 11:57:49

Danke auch an Kuno für die Scripte!

Es hat beim 2ten Versuch geklappt. Beim ersten mal war da noch irgendwas mit mime-type (debian-file) durcheinander gewürfelt, keine Ahnung wie das passiert ist.
Windows 10 Pro (x64), 1909 18363 | Linux Mint 19.3 (x64)

Kuno
SoftMaker Volunteers
SoftMaker Volunteers
Beiträge: 2838
Registriert: 02.03.2004 12:31:01
Wohnort: Osnabrück

Re: Problem mit UpdatePack 933 unter Linux Mint 19

Beitrag von Kuno » 22.06.2018 12:21:52

ts-soft hat geschrieben:
22.06.2018 11:57:49
Danke auch an Kuno für die Scripte!

Es hat beim 2ten Versuch geklappt. Beim ersten mal war da noch irgendwas mit mime-type (debian-file) durcheinander gewürfelt, keine Ahnung wie das passiert ist.
Schön, dass es geklappt hat. Bei mir hat das Script dann letztendlich auch funktioniert - hat aber gedauert, wahrscheinlich war ich zu ungeduldig.
Systeme
Home: Core2Duo T9600 @ 2.80GHz 4Gb Ram - Intel GM45 - Mesa 19.3.3-1
Debian Sid/Unstable Openbox - Linux 5.7.0-rc5-amd64
--------------------------------------------------------
Office: Core2Duo P8700 @ 2.53GHz 4Gb Ram - Intel GM45 - Mesa 18.3.6-2+deb10u1
Debian Buster Openbox - Linux 5.7.0-rc5-amd64

Zausl
Beiträge: 56
Registriert: 08.10.2015 22:09:04
Wohnort: Göttingen

Re: Problem mit UpdatePack 933 unter Linux Mint 19

Beitrag von Zausl » 22.06.2018 14:01:16

Hallo Allerseits,

ich habe auch das o.g. Problem auf Ubuntu 18.04 beobachtet. Softmaker Office 2018 benötigt libcurl3 während andere Tools wie z.B. schon sowas einfaches wie "uget" libcurl4 verwenden.

Es wäre wirklich sehr entgegenkommend, wenn zeitnah ein SofmakerOffice Update herauskommen würde das den Abhängigkeitskonflikt libcurl3 vs libcurl4 beseitigen würde bzw. libcurl4 Kompatibilität herstellt.

martin-k
SoftMaker Team
SoftMaker Team
Beiträge: 5768
Registriert: 03.12.2003 14:32:06
Kontaktdaten:

Re: Problem mit UpdatePack 933 unter Linux Mint 19

Beitrag von martin-k » 22.06.2018 14:02:46

Daran arbeiten wir gerade. Das Problem besteht darin, dass Ubuntu und Mint sich libcurl4 einbilden, während andere Systeme wie Debian libcurl3 verwenden. Und beide gleichzeitig installieren geht bei Linux nicht :-(
Martin Kotulla
SoftMaker Software GmbH

martin-k
SoftMaker Team
SoftMaker Team
Beiträge: 5768
Registriert: 03.12.2003 14:32:06
Kontaktdaten:

Re: Problem mit UpdatePack 933 unter Linux Mint 19

Beitrag von martin-k » 22.06.2018 15:57:09

Wir haben jetzt sowohl auf dem Downloadserver als auch im Repository die 933er-DEB-Dateien aktualisiert, sodass SoftMaker Office sich sowohl mit libcurl3 als auch libcurl4 zufriedengibt. Bitte eines dieser Pakete installieren, dann sollte dieses ärgerliche Problem beseitigt sein.
Martin Kotulla
SoftMaker Software GmbH

Benutzeravatar
ts-soft
SoftMaker Volunteers
SoftMaker Volunteers
Beiträge: 460
Registriert: 12.11.2011 19:29:30
Wohnort: Berlin

Re: Problem mit UpdatePack 933 unter Linux Mint 19

Beitrag von ts-soft » 22.06.2018 18:46:49

Funktioniert gut :D
Das Paket wird nicht mehr zurückgehalten und fehlerfrei installiert (obwohl das war es schon).

Danke,
Thomas
Windows 10 Pro (x64), 1909 18363 | Linux Mint 19.3 (x64)

Antworten

Zurück zu „SoftMaker Office 2018 für Linux (Allgemein)“