Standard Schriftart

Fehlerberichte, Hilfe und Anregungen zu PlanMaker 2018 für Windows

Moderator: SoftMaker Team

papa willi
Beiträge: 99
Registriert: 02.11.2017 12:26:54
Wohnort: Rosenheim

Re: Standard Schriftart

Beitrag von papa willi » 27.12.2017 20:41:56

@Ebbi,
ich glaub ich hab die Lösung zum dauerhaften Ändern der Schriftart.

Zitat aus der Hilfe:
Sie ist gänzlich leer und enthält lediglich die Standardzeichenvorlage "Normal" sowie die Standardzellenvorlage "Normal".
Wenn man ein Vorlage mit dauerhaft geänderter Schrift-Art und -Größe braucht, dann muss man zum Ändern in "Format -> Zellenvorlage -> Vorlage "Normal" gehen, dort Zeichenformat wählen und die gewünschte Schriftart und Größe einstellen.

Dieses Dokument wieder mit "Speichern unter" als "PlanMaker-Vorlage (*.pmvx)", entweder als Normal.pmvx und die Vorhandene überschreiben, oder unter einen anderen Namen und diese anschließend in PlanMaker unter "Datei Neu -> weitere ->" markieren und als "Neuer Standard" wählen. PlanMaker schreibt sie anschließend in die Systemregistrierung.

Dank an Panosis für die Unterstützung.

FFF
SoftMaker Volunteers
SoftMaker Volunteers
Beiträge: 1209
Registriert: 11.06.2013 22:30:18

Re: Standard Schriftart

Beitrag von FFF » 27.12.2017 22:32:50

papa willi hat geschrieben:
27.12.2017 20:41:56
Wenn man ein Vorlage mit dauerhaft geänderter Schrift-Art und -Größe braucht, dann muss man zum Ändern in "Format -> Zellenvorlage -> Vorlage "Normal" gehen, dort Zeichenformat wählen und die gewünschte Schriftart und Größe einstellen.

Dieses Dokument wieder mit "Speichern unter" als "PlanMaker-Vorlage (*.pmvx)", entweder als Normal.pmvx und die Vorhandene überschreiben, oder unter einen anderen Namen und diese anschließend in PlanMaker unter "Datei Neu -> weitere ->" markieren und als "Neuer Standard" wählen. PlanMaker schreibt sie anschließend in die Systemregistrierung.
Das funktioniert - einzige Einschränkung bei mir, wenn ich unten bei Tabelle1 per Kontextmenu (oder auch neben dem Namen per Icon), "Einfügen" wähle, nimmt PM doch wieder das verflixte Arial 10 für das neue Tabellenblatt ;-)
EDIT: Genau lesen hilft: ich hatte "Format-Zeichenvorlage" bearbeitet - wählt man tatsächlich "Format-ZELLENVorlage" und folgt der Anleitung, klappt es! Danke =D>
Mit freundlichem Gruß
Karl
emC 7 & SM 2016 rev766.0331 @ W8.1/64 /// SM 2018 rev. 972/1023/64, klassisches Menu
16GB Ram; Core i5-3450 mit integriertem Intel HDGraphics 4000, Treiber 10.18.10.4276;
2560x1440 Monitor 100% Darstellungsgröße /// LaserJet 1200 per USB via Fritzbox 6490.

Panosis
SoftMaker Volunteers
SoftMaker Volunteers
Beiträge: 2594
Registriert: 24.04.2008 00:02:12

Re: Standard Schriftart

Beitrag von Panosis » 28.12.2017 10:01:52

Dummerweise scheint sich da aber noch ein Würmchen zu verstecken, das SoftMaker sich nach den Feiertagen ansehen sollte.

Bei mir funktioniert es zwar, die geänderte Vorlagendatei abzuspeichern. Ich kann sie auch wieder laden.
Nur will PlanMaker in der Settings-Datei einfach einen anderen Pfad haben, der da lautet:
TemplateFile0=C:\Users\XXXXXXXXX\Documents\SoftMaker\Templates 2018\Deutsch\Deutsch\PlanMaker\Normal.pmvx
Einen Ordner "Deutsch\Deutsch" gibt es aber nicht. Also wird auch die Vorlage nicht gefunden, da sie ja in dem nicht vorhandenen Ordner nicht vorhanden sein kann.

Korrigiere ich von Hand den Pfad in der Settings-Datei und entferne das überflüssige "\Deutsch\", ist nach dem nächsten Start genau dieser falsche Pfad wieder vorhanden. Das sollte sich SoftMaker ansehen.

papa willi
Beiträge: 99
Registriert: 02.11.2017 12:26:54
Wohnort: Rosenheim

Re: Standard Schriftart

Beitrag von papa willi » 28.12.2017 12:05:20

Hallo Panosis,

in welcher Settings-Datei haben sie den Eintrag "...\Deutsch\Deutsch\... "?

Ich habe die Windows Registrierung durchsucht: kein Falscheintrag.
Mit dem PlanMaker Dateimanager: kein Falscheintrag.
Mit dem Total Comander: kein Falscheintrag.

Die Abspeicherung meiner geänderten Vorlage erfolgte im Richtigen Verzeichnis. Ich kann die geänderte Vorlage im PlanManager sowohl manuell Starten, wie auch fest als "Neuen Standard" zuweisen. Nach jedem Neustart von PlanMaker wird die zugewiesene geänderte Vorlage als Default-Vorgabe geöffnet.

Windows 10 Pro 64Bit
SoftMaker Offic 2018 Pro (rev.920.1214) 64bit

Kuno
SoftMaker Volunteers
SoftMaker Volunteers
Beiträge: 2625
Registriert: 02.03.2004 12:31:01
Wohnort: Osnabrück

Re: Standard Schriftart

Beitrag von Kuno » 28.12.2017 12:18:11

papa willi hat geschrieben:
28.12.2017 12:05:20
Hallo Panosis,

in welcher Settings-Datei haben sie den Eintrag "...\Deutsch\Deutsch\... "?
Panosis meint vermutlich die pm18config.ini im Softmaker\Settings - Ordner.
Systeme
Home: Core2Duo T9600 @ 2.80GHz 4Gb Ram - Intel GM45 - Mesa 19.1.2-1
Debian Sid/Unstable Openbox - Linux 5.2.0-8.1-liquorix-amd64
--------------------------------------------------------
Office: Core2Duo P8700 @ 2.53GHz 4Gb Ram - Intel GM45 - Mesa 19.1.2-1
Debian Buster Openbox - Linux 5.2.0-8.1-liquorix-amd64

papa willi
Beiträge: 99
Registriert: 02.11.2017 12:26:54
Wohnort: Rosenheim

Re: Standard Schriftart

Beitrag von papa willi » 28.12.2017 12:51:51

Danke für den Hinweis.

Ich kann aber (zum Glück) auch in der "pmw18config.ini" keinen solchen Eintrag finden.

pmw18config.ini.jpg
pmw18config.ini.jpg (180.14 KiB) 2114 mal betrachtet

Panosis
SoftMaker Volunteers
SoftMaker Volunteers
Beiträge: 2594
Registriert: 24.04.2008 00:02:12

Re: Standard Schriftart

Beitrag von Panosis » 28.12.2017 14:39:59

Wenn es keinen solchen fehlerhaften Pfadeintrag gibt, ist es ja gut.
Allerdings ist ein ähnliches Problem, wie ich es bei mir habe, bereits früher aufgetreten. Vielleicht tritt es noch bei anderen auf. Daher wäre es gut, wenn SoftMaker sich das nochmal ansähe.

Ebbi
Beiträge: 7
Registriert: 25.12.2017 10:03:33

Re: Standard Schriftart

Beitrag von Ebbi » 28.12.2017 17:42:40

@papa willi:
Hab mal die Anleitung probiert. Bei mir startet er immer wieder mit Arial 10.

Edit: Ok. Wenn ich Planmaker via exe öffne, habe ich meine Garamond. Nur übers Kontextmenü bleibt er bei Arial 10.

Antworten

Zurück zu „PlanMaker 2018 für Windows“