träge bei größeren Dateien **gelöst**

Fehlerberichte, Hilfe und Anregungen zu TextMaker 2018 für Windows

Moderator: SoftMaker Team

Antworten
Toma
Beiträge: 39
Registriert: 04.12.2017 16:43:53

träge bei größeren Dateien **gelöst**

Beitrag von Toma » 09.05.2018 22:37:18

** Gelöst: Mit dem letzten Update ist die Trägheit verschwunden!!

Ist mir lansam peinlich, ständig zu lamentieren:

Datei 61 Tsd Wörter, angezeigte 137 Seiten.
Mit zunehmender Größe der Datei werden Cursorbewegungen immer träger, je weiter unten in der Datei man sich befindet. Bin z.Zt. so auf Seite 130. Es ist teilweise zum Verzweifeln. Ich will ich mit den Pfeiltasten schnell mal 5 Zeichen zur Seite, um einen Buchstaben zu korrigieren. Manchmal bleibt dann der Cursor 1-2(!) Sekunden mitten drin stehen (z.Bsp. nach 3 Zeichen), so dass ich, in dem Glauben, ich hätte zuwenig verschoben, noch 2mal Pfeiltaste drücke und dann korrigiere. Leider dann 2 Zeichen zu weit. Also Korrektur der Korrektur und wieder zurück. Bin ich dabei zu schnell, passiert das wieder, diesmal in der anderen Richtung. Ich müsste immer lange genug warten, bis der Cursor seine endgültige Position eingenommen hat. Und das, wo man eigentlich gewohnt ist, schnell zu tippen.
Mit der Maus könnte ich zwar schnell die Position antippen (5 Zeichen neben der aktuellen Cursorposition!), aber den Schreibfluss stört das enorm. Außerdem wird die Korrektur selbst dann wieder träge ausgeführt.
Der endgültige Text wird einmal rund 80 Tsd Wörter umfassen. Deutsch. Was erwartet mich bis dahin? Und es kommen noch größere Dateien.

Ich habe die Datei eben mal ins Word 2000(!) geladen. Null Probleme. Alles so, als wäre da nur 1 Seite geladen. Warum?
Mache nur ich diese Erfahrung?

Gruß Toma
Zuletzt geändert von Toma am 07.06.2018 23:23:10, insgesamt 1-mal geändert.

FFF
SoftMaker Volunteers
SoftMaker Volunteers
Beiträge: 1017
Registriert: 11.06.2013 22:30:18

Re: träge bei größeren Dateien

Beitrag von FFF » 09.05.2018 23:57:21

Toma hat geschrieben:
09.05.2018 22:37:18
Ist mir lansam peinlich, ständig zu lamentieren:
...
Mache nur ich diese Erfahrung?
Ne - wie eine Suche rel. leicht ergeben hätte, ist das in ein paar Threads ein Thema. "Schuldig" ist die eingeschaltete Hintergrundrechtschreibkontrolle vom Dudenkorrektor. Warum das so ist, ist noch unklar, ein ähnliches Bild gab es auch in TM2016 anfangs.
Workaround: Diese Funktion einfach abschalten. Rechtschreibung prüfen, gerade in so einem großen Dokument, macht eh' am Ende beim Lektorat mehr Sinn...
Mit freundlichem Gruß
Karl
emC 7 & SM 2016 rev766.0331 @ W8.1/64
SM 2018 rev. 944/1211/64, klassisches Menu
16GB Ram; Intel-"Onboard" Grafik, 2560x1440 Monitor 100% Darstellungsgröße
LaserJet 1200 per USB via Fritzbox 6490.

Toma
Beiträge: 39
Registriert: 04.12.2017 16:43:53

Re: träge bei größeren Dateien

Beitrag von Toma » 10.05.2018 12:38:38

FFF hat geschrieben:
09.05.2018 23:57:21
wie eine Suche rel. leicht ergeben hätte, ist das in ein paar Threads ein Thema. "Schuldig" ist die eingeschaltete Hintergrundrechtschreibkontrolle vom Dudenkorrektor. ... macht eh' am Ende beim Lektorat mehr Sinn...
Ich hatte nach "langsam" gesucht. Schien mir sinnvoll und tut es noch. Ergebnis: 11, davon ging es zum Ersten um Formeln und zum Zweiten um ein Problem mit dem Mac.

Den Tipp mit "ausschalten" nutze ich jetzt, aber widerwillig. Ob es Sinn macht, erst am Ende nochmal alles nach Fehlern durchzugehen, muss jeder für sich entscheiden. Ich möchte sofort korrigieren, bin es so gewohnt, weiß also, dass es geht. Es gibt auch gute Gründe dafür. Ich lektoriere nicht.

Gruß
Toma

Benutzeravatar
Get
Beiträge: 153
Registriert: 08.12.2014 13:39:39
Kontaktdaten:

Re: träge bei größeren Dateien

Beitrag von Get » 10.05.2018 14:25:45

Mein Weg: Ich zerlege sehr große Dateien in kleinere (z. B. Kapitel) und füge das am Ende zu einer großen Datei zusammen. Dazu habe ich mal ein "Autorensystem" gemacht (viewtopic.php?f=228&t=23081), das bei SM 2018 aber nur in der 32-Bit Version funktioniert, wg. einer fehlenden 64-Bit dll in Basic.
Gerhard Etzel
Autor (gerhard-etzel-buch.de). Meine Kriminalromane wurden mit Textmaker geschrieben!
Windows 10, SMO 2018 Prof.

Toma
Beiträge: 39
Registriert: 04.12.2017 16:43:53

Re: träge bei größeren Dateien

Beitrag von Toma » 10.05.2018 14:52:55

Get hat geschrieben:
10.05.2018 14:25:45
Mein Weg: Ich zerlege sehr große Dateien in kleinere
Das habe ich auch schon versucht. War aber unpraktisch. Zu oft muss ist die ganze Datei nach der Verwendung eines Wortes durchsuchen, oder einen Namen suchen, .... Ok, ich könnte die Teile im TM nebeneinander laden. Im Moment würde schon halbieren reichen. Mal sehen...

Gruß Toma

HStafo
Beiträge: 17
Registriert: 06.06.2017 17:08:22

Re: träge bei größeren Dateien

Beitrag von HStafo » 30.05.2018 14:45:57

Ich habe auch schon wiederholt und vor längerer Zeit auf dieses Phänomen hingewiesen, z.B. hier vor knapp einem Jahr:

viewtopic.php?f=275&t=23604#p112878

Daß hier keine Lösung gefunden wird, halte ich für sehr ärgerlich, zumal die träge Reaktion des Systems beim Schreiben schon bei recht kleinen Dokumenten auftritt.

Ich habe mir das Softmaker Office Pro wegen der Duden-Rechtschreibung gekauft - die Hunspell-Wörterbücher haben einen doch recht beschränkten Wortschatz. Wenn das Schnellschreiben mit 10 Fingern bei längeren Dokumenten wegen Fehlern bei der Programmierung nervt, dann kann ich eben Softmaker Office bzw. Textmaker als Kernelement nicht mehr nutzen. Und das wäre doch sehr schade!

Und: Die bei Word, Pyparus oder Open Office können's doch auch!

Meine DRINGENDE Bitte an die Entwickler: Nehmen Sie sich doch bitte endlich dieser Angelegenheit an, die schon seit x Monaten hier im Forum herumgeistert!

Danke.

McTesch
Beiträge: 110
Registriert: 13.10.2005 08:35:48
Wohnort: Wissen

Re: träge bei größeren Dateien

Beitrag von McTesch » 30.05.2018 15:15:32

HStafo hat geschrieben:
30.05.2018 14:45:57
Ich habe auch schon wiederholt und vor längerer Zeit auf dieses Phänomen hingewiesen, z.B. hier vor knapp einem Jahr:

viewtopic.php?f=275&t=23604#p112878

Daß hier keine Lösung gefunden wird, halte ich für sehr ärgerlich, zumal die träge Reaktion des Systems beim Schreiben schon bei recht kleinen Dokumenten auftritt.

Ich habe mir das Softmaker Office Pro wegen der Duden-Rechtschreibung gekauft - die Hunspell-Wörterbücher haben einen doch recht beschränkten Wortschatz. Wenn das Schnellschreiben mit 10 Fingern bei längeren Dokumenten wegen Fehlern bei der Programmierung nervt, dann kann ich eben Softmaker Office bzw. Textmaker als Kernelement nicht mehr nutzen. Und das wäre doch sehr schade!

Und: Die bei Word, Pyparus oder Open Office können's doch auch!

Meine DRINGENDE Bitte an die Entwickler: Nehmen Sie sich doch bitte endlich dieser Angelegenheit an, die schon seit x Monaten hier im Forum herumgeistert!

Danke.
Hallo, mir geht es ganz genauso. Ich habe mir Office Universal zugelegt und nutze SMO auf Windows, Linux und Mac und überall ist es das Gleiche mit dem Laggen. Ich bin, ehrlich gesagt, ziemlich enttäuscht und bereue auch schon, dass ich nicht noch gewartet und erst mal die Probeversion bis zum letzten Tag genutzt habe. Eigentlich habe ich von LibreOffice gewechselt, weil mir, einem alten Kunden, Softmaker auf meinem MacBook Air gefälliger vorkam als LibreOffice (mit Pages konnte ich mich nicht anfreunden) und weil es auf allen drei großen Plattformen läuft. Auch das Scrollen auf dem MacBook ist sehr holprig, auch nach der Revision.
2018 ist die erste Version, die mich nicht zufriedenstellt.

Gariniranus
Beiträge: 409
Registriert: 09.04.2009 15:22:53

Re: träge bei größeren Dateien

Beitrag von Gariniranus » 30.05.2018 19:40:22

Wer mag kann sich bei Papyrus im Duden-Verzeichnis umsehen: "Die beschleunigte Einzelwortprüfung kommt dann zum Tragen, wenn
die Duden Proof Factory in den Prüfmodi DpfCmSpellFast und DpfCmSpellFastSuggest benutzt wird UND der Parameter singleLine aktiv ist."

Weitere technische Details werden ebenfalls angegeben. Nach dem merkwürdigen ct-Test in Sachen Duden würde ich vorschlagen gleich auf die EPC-Seite zu gehen und dort weitere Informationen beim Service einzuholen.

Antworten

Zurück zu „TextMaker 2018 für Windows“