Installierter Font wird in TM nicht angezeigt

Fehlerberichte, Hilfe und Anregungen zu FreeOffice TextMaker 2016 für Linux

Moderator: SoftMaker Team

Antworten
Copytexter
Beiträge: 10
Registriert: 26.04.2015 15:12:10

Installierter Font wird in TM nicht angezeigt

Beitrag von Copytexter » 21.11.2016 13:46:17

Hallo allerseits,

vor einiger Zeit bin ich komplett auf Linux umgestiegen und nutze seitdem SM FreeOffice 2016 (vorher: SMO 2012 Pro unter Windows). Sehr gute Software, die meinen Anforderungen als nur gelegentlicher Nutzer klassischer Office-Programme vollends genügt.

Ein Problem gibt es allerdings: Ich habe eine aus 17 Schnitten bestehende Schriftfamilie, die ich seit vielen Jahren bevorzugt für alle persönlichen Texte nutze. Es handelt sich um TTF-Dateien, die sich allesamt problemlos unter Linux (Mint 17.3) installieren ließen und bspw. bei der Schriftauswahl in Libre Office auch vollständig angeboten werden.

In Textmaker werden sie jedoch nicht angezeigt, weder in der Auswahl-Liste noch in den Einstellungen (was vermutlich dieselbe Ursache hat). Öffne ich ein Dokument mit besagter Schrift, dann wird es korrekt angezeigt und kann auch problemlos bearbeitet sowie als PDF exportiert werden, was für mich darauf hindeutet, dass auf die Schriftbeschreibung zugegriffen werden kann. Der Name der Schrift, also dieses einen Schnittes, findet sich dann mit Times, Arial und Courier im oberen Teil der Auswahlliste, hat jedoch ein anderes Symbol (Drucker?).

Woran kann es liegen, dass die Schriften in Textmaker nicht erkannt bzw. angezeigt werden?

Über Tipps und sachdienliche Hinweise würde ich mich freuen. Vielen Dank!

sven-l
SoftMaker Team
SoftMaker Team
Beiträge: 12548
Registriert: 09.04.2008 09:50:06
Wohnort: Nürnberg
Kontaktdaten:

Re: Installierter Font wird in TM nicht angezeigt

Beitrag von sven-l » 22.11.2016 10:10:57

Vermutlich liegen die Schriften in einem Ordner, den TextMaker nicht nach Schriften durchsucht. Sie können den Schriftenpfad unter Weiteres=>Einstellungen=>System nachtragen.
Sven Leßmann
SoftMaker Software GmbH

Copytexter
Beiträge: 10
Registriert: 26.04.2015 15:12:10

Re: Installierter Font wird in TM nicht angezeigt

Beitrag von Copytexter » 22.11.2016 16:31:13

Ja, der Fontordner liegt in ~/.local/share/fonts, also dort, wo von Benutzern installierte Schriften bei Linux (Ubuntu ff) immer abgelegt (und von anderen Programmen auch gefunden) werden. Hatte bei den TM-Einstellungen sogar nach einer Möglichkeit gesucht, einen Pfad anzugeben, allerdings im Reiter "Schriften". Habe ihn jetzt eingetragen und nun zeigt auch TextMaker die Fonts korrekt an (eine andere Möglichkeit wäre vermutlich gewesen, den Font-Ordner mit root-Rechten manuell im globalen Schriftordner /usr/share/fonts/ zu speichern). Danke sehr.

Benutzeravatar
Michael Uplawski
Beiträge: 795
Registriert: 09.06.2010 14:27:54
Wohnort: Canton Magny, Normandie

Re: Installierter Font wird in TM nicht angezeigt

Beitrag von Michael Uplawski » 22.11.2016 18:13:24

Copytexter hat geschrieben:Ja, der Fontordner liegt in ~/.local/share/fonts, also dort, wo von Benutzern installierte Schriften bei Linux (Ubuntu ff) immer abgelegt (und von anderen Programmen auch gefunden) werden.
Dort liegt bei mir gar nichts. Heute abend, auf einem Mint-System, ist der Ordner ebenfalls leer. Alle Schriften, die ich installiert habe, liegen in /usr/share/fonts, zumal die „Installation“ darin besteht, sie dort hinzukopieren... :-k
Mein problemloses Linux-System: Debian Buster/Sid mit OpenBox/Rox Desktop.
People should go where they are not supposed to go, say what they are not supposed to say and stay, when they are told to leave.
Bild(Howard Zinn)

Kuno
SoftMaker Volunteers
SoftMaker Volunteers
Beiträge: 2309
Registriert: 02.03.2004 12:31:01
Wohnort: Osnabrück

Re: Installierter Font wird in TM nicht angezeigt

Beitrag von Kuno » 22.11.2016 20:50:41

Michael Uplawski hat geschrieben:Dort liegt bei mir gar nichts... :-k
Und bei mir gibt es den Ordner nicht einmal. Per Paketmanager installierte fonts sind unter /usr/share/fonts zu finden (So sollte es auch sein...).
Wenn ich fonts anders einbinden will, kopiere ich die einfach in den selbst erstellten Ordner ".fonts" unter /home/user/ . Da hab ich nach der Migration von Win zu Linux alle Schriften aus dem Windows/Fonts - Ordner reinkopiert. Und kann alle unter TM-Linux nutzen.
System
Core2Duo T9600 @ 2.80GHz 4Gb Ram - Dual Boot - Intel GM45 - Mesa 17.3.5-1
Debian Sid/Unstable Openbox - Linux 4.17.0-trunk-amd64
--------------------------------------------------------
Core2Duo P8700 @ 2.53GHz 4Gb Ram - Intel GM45 - Mesa13.0.6-1+b2
Debian Stretch Openbox - Linux 4.17.0-trunk-amd64

Copytexter
Beiträge: 10
Registriert: 26.04.2015 15:12:10

Re: Installierter Font wird in TM nicht angezeigt

Beitrag von Copytexter » 04.12.2016 13:50:09

Sorry, ich hatte nicht mit weiteren Kommentaren gerechnet und deshalb auch nicht nachgesehen. Zur Klärung des Sachverhaltes
erscheint mir jedoch ein Nachtrag angebracht ...
Michael Uplawski hat geschrieben:Dort liegt bei mir gar nichts. Heute abend, auf einem Mint-System, ist der Ordner ebenfalls leer. Alle Schriften, die ich installiert habe, liegen in /usr/share/fonts, zumal die „Installation“ darin besteht, sie dort hinzukopieren... :-k
Nein, "Installation" meint hier eben nicht manuelles "Kopieren", bei dem man das Zielverzeichnis ja von vornherein selbst bestimmt. Wenn man als normaler Benutzer mit Linux Mint 17.3 Cinnamon eine Font-Datei im Schriftartenbetrachter öffnet - z. B. per Doppelklick -, dann wird eine Vorschau des Schriftbildes in verschiedenen Größen angezeigt, und rechts oben befinden sich die Buttons "Info" und "Installieren" (sic!). Klickt man auf letzteren, dann wird die Font-Datei automatisch in folgenden Ordner kopiert:

/home/USER/.local/share/fonts

Wo sie, ich wiederhole es gern, von anderen Anwendungsprogrammen auch gefunden wird. Von FreeOffice jedoch nur dann, wenn man den Pfad in den Einstellungen manuell nachträgt (siehe Post vom 22.11.). Nimmt man ihn wieder heraus, ist auch die Schrift in FreeOffice nicht mehr verfügbar.

Genau so wird es übrigens auch auf https://wiki.ubuntuusers.de/Schriften/#Installation beschrieben, lediglich mit dem Unterschied, dass bei mir keine weiteren Unterordner für die verschiedenen Fonttypen (bspw. /truetype) angelegt werden.

Natürlich kann man es auch ganz anders machen, aber das war ja nicht die Frage.

sven-l
SoftMaker Team
SoftMaker Team
Beiträge: 12548
Registriert: 09.04.2008 09:50:06
Wohnort: Nürnberg
Kontaktdaten:

Re: Installierter Font wird in TM nicht angezeigt

Beitrag von sven-l » 07.12.2016 09:39:33

Copytexter hat geschrieben:Sorry, ich hatte nicht mit weiteren Kommentaren gerechnet und deshalb auch nicht nachgesehen. Zur Klärung des Sachverhaltes
erscheint mir jedoch ein Nachtrag angebracht ...
Michael Uplawski hat geschrieben:Dort liegt bei mir gar nichts. Heute abend, auf einem Mint-System, ist der Ordner ebenfalls leer. Alle Schriften, die ich installiert habe, liegen in /usr/share/fonts, zumal die „Installation“ darin besteht, sie dort hinzukopieren... :-k
Nein, "Installation" meint hier eben nicht manuelles "Kopieren", bei dem man das Zielverzeichnis ja von vornherein selbst bestimmt. Wenn man als normaler Benutzer mit Linux Mint 17.3 Cinnamon eine Font-Datei im Schriftartenbetrachter öffnet - z. B. per Doppelklick -, dann wird eine Vorschau des Schriftbildes in verschiedenen Größen angezeigt, und rechts oben befinden sich die Buttons "Info" und "Installieren" (sic!). Klickt man auf letzteren, dann wird die Font-Datei automatisch in folgenden Ordner kopiert:

/home/USER/.local/share/fonts

Wo sie, ich wiederhole es gern, von anderen Anwendungsprogrammen auch gefunden wird. Von FreeOffice jedoch nur dann, wenn man den Pfad in den Einstellungen manuell nachträgt (siehe Post vom 22.11.). Nimmt man ihn wieder heraus, ist auch die Schrift in FreeOffice nicht mehr verfügbar.

Genau so wird es übrigens auch auf https://wiki.ubuntuusers.de/Schriften/#Installation beschrieben, lediglich mit dem Unterschied, dass bei mir keine weiteren Unterordner für die verschiedenen Fonttypen (bspw. /truetype) angelegt werden.

Natürlich kann man es auch ganz anders machen, aber das war ja nicht die Frage.
Ich werde das als Verbesserungsvorschlag für SoftMaker Office / FreeOffice für Linux melden.
Sven Leßmann
SoftMaker Software GmbH

Benutzeravatar
Michael Uplawski
Beiträge: 795
Registriert: 09.06.2010 14:27:54
Wohnort: Canton Magny, Normandie

Re: Installierter Font wird in TM nicht angezeigt

Beitrag von Michael Uplawski » 21.12.2016 08:15:50

sven-l hat geschrieben:Ich werde das als Verbesserungsvorschlag für SoftMaker Office / FreeOffice für Linux melden.
Für die Ubuntu-Version. Ich spreche es mal an und aus und schlage Ω vor.
Mein problemloses Linux-System: Debian Buster/Sid mit OpenBox/Rox Desktop.
People should go where they are not supposed to go, say what they are not supposed to say and stay, when they are told to leave.
Bild(Howard Zinn)

Antworten

Zurück zu „FreeOffice TextMaker 2016 für Linux“