SoftMaker Office 2016 startet nicht (Segmentation fault)

Dieses Forum ist nur für Fragen, Anregungen und Fehlerberichte gedacht, die SoftMaker Office 2016 für Linux allgemein betreffen. Für alles andere bitte die programmspezifischen Foren benutzen.

Moderator: SoftMaker Team

Antworten
Rostbraten
Beiträge: 4
Registriert: 13.06.2017 14:19:13

SoftMaker Office 2016 startet nicht (Segmentation fault)

Beitrag von Rostbraten » 13.06.2017 14:26:35

Moin Moin,

Ich nutzte eine Zeit lang Linux Mint 18.1 Mate x64. Dort funktionierte SoftMaker Office 2016 die ganze Zeit ohne Probleme. Jetzt leider startet es nicht mehr. Unter der Konsole bekomme ich die Fehlermeldung "Segmentation fault". Ich recherchierte natürlich selber einige Zeit lang, doch bin ich auf keine Lösung gestoßen leider.

Ich hatte es deinstalliert und neu installiert, gleiche Ergebnis. Nun habe ich Linux Mint 18.1 Cinnamon x64 neu installiert, Kernel 4.10.X installiert und alles aktualisiert. SoftMaker Office 2016 installiert, beim Installieren keine Fehlermeldung, auch unter der Konsole mit den Tipps installiert, keine Fehlermeldung. Will ich es starten passiert nichts, starte ich es unter der Konsole, gleiche Fehlermeldung "Segmentation fault".

Könnt ihr mir weiterhelfen?

Mit besten Grüßen

PS: Hier meine Systemdaten zur weiteren Hilfe.

System: Host: andre-HP-355-G2 Kernel: 4.10.0-22-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.2.7 (Gtk 3.18.9-1ubuntu3.3) dm: mdm Distro: Linux Mint 18.1 Serena
Machine: System: Hewlett-Packard (portable) product: HP 355 G2 v: 0998100000000010000600007
Mobo: Hewlett-Packard model: 22C2 v: KBC Version 86.09 Bios: Insyde v: F.12 date: 08/03/2016
Chassis: type: 10
CPU: Quad core AMD A4-6210 APU with AMD Radeon R3 Graphics (-MCP-) cache: 8192 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 14372
clock speeds: min/max: 1000/1800 MHz 1: 1650 MHz 2: 1200 MHz 3: 1350 MHz 4: 1500 MHz
Graphics: Card-1: Advanced Micro Devices [AMD/ATI] Mullins [Radeon R3 Graphics]
bus-ID: 00:01.0 chip-ID: 1002:9850
Card-2: Advanced Micro Devices [AMD/ATI] Jet XT [Radeon R5 M240]
bus-ID: 01:00.0 chip-ID: 1002:6664
Display Server: X.Org 1.18.4 drivers: ati,amdgpu (unloaded: fbdev,vesa,radeon)
Resolution: 1366x768@59.99hz
GLX Renderer: Gallium 0.4 on AMD MULLINS (DRM 3.9.0 / 4.10.0-22-generic, LLVM 5.0.0)
GLX Version: 3.0 Mesa 17.2.0-devel - padoka PPA Direct Rendering: Yes
Audio: Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller
driver: snd_hda_intel bus-ID: 00:14.2 chip-ID: 1022:780d
Card-2 Advanced Micro Devices [AMD/ATI] Kabini HDMI/DP Audio
driver: snd_hda_intel bus-ID: 00:01.1 chip-ID: 1002:9840
Sound: Advanced Linux Sound Architecture v: k4.10.0-22-generic
Network: Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169 v: 2.3LK-NAPI port: 2000 bus-ID: 02:00.0 chip-ID: 10ec:8168
IF: eno1 state: down mac: <filter>
Card-2: Intel Wireless 7260 driver: iwlwifi bus-ID: 06:00.0 chip-ID: 8086:08b1
IF: wlp6s0 state: up mac: <filter>
Drives: HDD Total Size: 256.1GB (9.0% used)
ID-1: /dev/sda model: Samsung_SSD_850 size: 256.1GB serial: S251NXAG837040A
Partition: ID-1: / size: 219G used: 7.2G (4%) fs: ext4 dev: /dev/dm-0
ID-2: /boot size: 473M used: 115M (26%) fs: ext2 dev: /dev/sda2
ID-3: swap-1 size: 16.06GB used: 0.00GB (0%) fs: swap dev: /dev/dm-1
RAID: System: supported: N/A
No RAID devices: /proc/mdstat, md_mod kernel module present
Unused Devices: none
Sensors: System Temperatures: cpu: 57.5C mobo: 46.0C gpu: 46.0,55.0
Fan Speeds (in rpm): cpu: N/A
Repos: Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
deb http: //mirror.netcologne.de/linuxmint/packages serena main upstream import backport
deb http: //ftp.uni-mainz.de/ubuntu xenial main restricted universe multiverse
deb http: //ftp.uni-mainz.de/ubuntu xenial-updates main restricted universe multiverse
deb http: //ftp.uni-mainz.de/ubuntu xenial-backports main restricted universe multiverse
deb http: //security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
deb http: //archive.canonical.com/ubuntu/ xenial partner
Active apt sources in file: /etc/apt/sources.list.d/paulo-miguel-dias-mesa-xenial.list
deb http: //ppa.launchpad.net/paulo-miguel-dias/mesa/ubuntu xenial main
deb-src http: //ppa.launchpad.net/paulo-miguel-dias/mesa/ubuntu xenial main
Info: Processes: 209 Uptime: 44 min Memory: 1087.2/15000.3MB
Init: systemd v: 229 runlevel: 5 default: 2 Gcc sys: 5.4.0
Client: Unknown python2.7 client inxi: 2.2.35

Rostbraten
Beiträge: 4
Registriert: 13.06.2017 14:19:13

Re: SoftMaker Office 2016 startet nicht (Segmentation fault)

Beitrag von Rostbraten » 13.06.2017 17:52:51

Nach weiterer Recherche, sende ich euch erstmal, was strace dazu sagt:

execve("/usr/bin/textmaker16", ["textmaker16"], [/* 48 vars */]) = 0
brk(NULL) = 0x565484b59000
access("/etc/ld.so.nohwcap", F_OK) = -1 ENOENT (No such file or directory)
mmap(NULL, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f6f0ee5f000
access("/etc/ld.so.preload", R_OK) = -1 ENOENT (No such file or directory)
open("/etc/ld.so.cache", O_RDONLY|O_CLOEXEC) = 3
fstat(3, {st_mode=S_IFREG|0644, st_size=138379, ...}) = 0
mmap(NULL, 138379, PROT_READ, MAP_PRIVATE, 3, 0) = 0x7f6f0ee3d000
close(3) = 0
access("/etc/ld.so.nohwcap", F_OK) = -1 ENOENT (No such file or directory)
open("/lib/x86_64-linux-gnu/libc.so.6", O_RDONLY|O_CLOEXEC) = 3
read(3, "\177ELF\2\1\1\3\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0P\t\2\0\0\0\0\0"..., 832) = 832
fstat(3, {st_mode=S_IFREG|0755, st_size=1864888, ...}) = 0
mmap(NULL, 3967392, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x7f6f0e873000
mprotect(0x7f6f0ea32000, 2097152, PROT_NONE) = 0
mmap(0x7f6f0ec32000, 24576, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x1bf000) = 0x7f6f0ec32000
mmap(0x7f6f0ec38000, 14752, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x7f6f0ec38000
close(3) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f6f0ee3c000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f6f0ee3b000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f6f0ee3a000
arch_prctl(ARCH_SET_FS, 0x7f6f0ee3b700) = 0
mprotect(0x7f6f0ec32000, 16384, PROT_READ) = 0
mprotect(0x5654835ff000, 8192, PROT_READ) = 0
mprotect(0x7f6f0ee61000, 4096, PROT_READ) = 0
munmap(0x7f6f0ee3d000, 138379) = 0
getuid() = 1000
getgid() = 1000
getpid() = 4153
rt_sigaction(SIGCHLD, {0x5654833f3540, ~[RTMIN RT_1], SA_RESTORER, 0x7f6f0e8a84b0}, NULL, 8) = 0
geteuid() = 1000
brk(NULL) = 0x565484b59000
brk(0x565484b7a000) = 0x565484b7a000
getppid() = 4151
stat("/home/andre", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
stat(".", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
open("/usr/bin/textmaker16", O_RDONLY) = 3
fcntl(3, F_DUPFD, 10) = 10
close(3) = 0
fcntl(10, F_SETFD, FD_CLOEXEC) = 0
geteuid() = 1000
getegid() = 1000
rt_sigaction(SIGINT, NULL, {SIG_DFL, [], 0}, 8) = 0
rt_sigaction(SIGINT, {0x5654833f3540, ~[RTMIN RT_1], SA_RESTORER, 0x7f6f0e8a84b0}, NULL, 8) = 0
rt_sigaction(SIGQUIT, NULL, {SIG_DFL, [], 0}, 8) = 0
rt_sigaction(SIGQUIT, {SIG_DFL, ~[RTMIN RT_1], SA_RESTORER, 0x7f6f0e8a84b0}, NULL, 8) = 0
rt_sigaction(SIGTERM, NULL, {SIG_DFL, [], 0}, 8) = 0
rt_sigaction(SIGTERM, {SIG_DFL, ~[RTMIN RT_1], SA_RESTORER, 0x7f6f0e8a84b0}, NULL, 8) = 0
read(10, "#!/bin/sh\n# A script to run Text"..., 8192) = 135
clone(child_stack=0, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD, child_tidptr=0x7f6f0ee3b9d0) = 4154
wait4(-1, [{WIFSIGNALED(s) && WTERMSIG(s) == SIGSEGV}], 0, NULL) = 4154
--- SIGCHLD {si_signo=SIGCHLD, si_code=CLD_KILLED, si_pid=4154, si_uid=1000, si_status=SIGSEGV, si_utime=11, si_stime=2} ---
rt_sigreturn({mask=[]}) = 4154
write(2, "Segmentation fault\n", 19Segmentation fault
) = 19
read(10, "", 8192) = 0
exit_group(139) = ?
+++ exited with 139 +++

Als nächstes, bin ich auf den Tipp gekommen, textmaker16 ohne OpenGL zu starten. Es liege wohl wahrscheinlich an der Grafikkarte bzw. an dem Treiber, dieses kann sehr gut sein.

Ich habe also den Befehl "textmaker16 -disableopengl" eingegeben und es startet.

Entweder ich warte auf neue mesa treiber, wo vielleicht dadurch das Problem nun entstanden ist, oder es gibt von eurer Seite aus eine Lösung, um trotzdem mit OpenGL es wieder starten zu können?

sven-l
SoftMaker Team
SoftMaker Team
Beiträge: 12991
Registriert: 09.04.2008 09:50:06
Wohnort: Nürnberg
Kontaktdaten:

Re: SoftMaker Office 2016 startet nicht (Segmentation fault)

Beitrag von sven-l » 14.06.2017 08:55:19

In Ihrem Fall ist das Problem eine fehlende Bibliothek für das 32bit openGL unter 64bit Linux Mint. Wir wissen aber nicht genau welche, da dies bei jeder Distribution wieder anders sein kann.
Sven Leßmann
SoftMaker Software GmbH

Kuno
SoftMaker Volunteers
SoftMaker Volunteers
Beiträge: 2605
Registriert: 02.03.2004 12:31:01
Wohnort: Osnabrück

Re: SoftMaker Office 2016 startet nicht (Segmentation fault)

Beitrag von Kuno » 14.06.2017 10:24:58

sven-l hat geschrieben:In Ihrem Fall ist das Problem eine fehlende Bibliothek für das 32bit openGL unter 64bit Linux Mint. Wir wissen aber nicht genau welche, da dies bei jeder Distribution wieder anders sein kann.
Hier mal ein Scrennshot von meinem Debian-System mit dem, was Synaptic zu OpenGL auswirft.
2017-06-14--1497428465_1680x1050_scrot.png
2017-06-14--1497428465_1680x1050_scrot.png (195.53 KiB) 1680 mal betrachtet
Systeme
Home: Core2Duo T9600 @ 2.80GHz 4Gb Ram - Intel GM45 - Mesa 19.1.2-1
Debian Sid/Unstable Openbox - Linux 5.2.0-8.1-liquorix-amd64
--------------------------------------------------------
Office: Core2Duo P8700 @ 2.53GHz 4Gb Ram - Intel GM45 - Mesa 19.1.2-1
Debian Buster Openbox - Linux 5.2.0-8.1-liquorix-amd64

Rostbraten
Beiträge: 4
Registriert: 13.06.2017 14:19:13

Re: SoftMaker Office 2016 startet nicht (Segmentation fault)

Beitrag von Rostbraten » 15.06.2017 08:35:42

Vielen Dank für eure Hilfe.

Es gab heute ein weiteres Update für die Bibliothek für OpenGL. Es funktioniert wieder im normalen Modus.
Am besten belasse ich es dabei mit dem Update jetzt, das neueste ist ja nicht immer Vorteil.

Never change a running System.

Antworten

Zurück zu „SoftMaker Office 2016 für Linux (Allgemein)“