Datumsformat nur benutzerdefiniert

Fehlerberichte, Hilfe und Anregungen zu PlanMaker 2016 für Linux

Moderator: SoftMaker Team

Antworten
dbet
Beiträge: 43
Registriert: 03.01.2014 15:41:51

Datumsformat nur benutzerdefiniert

Beitrag von dbet » 22.12.2015 10:59:21

Als Datumsformat kann ich einstellen, was ich will, es ergibt immer ein benutzerdefiniertes Format. Vorgehen:
[*]Datum in Zelle eingeben
[*]diese Zelle anwählen
[*]Rechtsklick, Zelle, Zahlenformat wählen
[*]ist schon Benutzerdefiniert
[*]Auswahl von Datum/Zeit mit Format 01.01.2012
[*]OK
[*]Rechtsklick, Zelle, Zahlenformat
[*]ist wieder Benutzerdefiniert

Das führt dazu, dass andere Programme das Datum nicht richtig anzeigen. Das Problem ist auch im PlanMaker HD vorhanden.

Benutzeravatar
Michael Uplawski
Beiträge: 717
Registriert: 09.06.2010 14:27:54
Wohnort: Canton Magny, Normandie

Re: Datumsformat nur benutzerdefiniert

Beitrag von Michael Uplawski » 22.12.2015 12:53:16

Kann das Problem *nicht* bestätigen.
Im Gegentum. Gebe ich in einer völlig jungfräulichen Tabelle ein Datum ein, ist es eins. Und das Datumsformat der Formatdefinition folgt sogar meiner Eingabe.
dbet hat geschrieben:
  • Datum in Zelle eingeben
  • diese Zelle anwählen
  • Rechtsklick, Zelle, Zahlenformat wählen
  • ist schon Benutzerdefiniert
Das ist komisch. Wurde das Dokument aus einer anderen Anwendung gespeichert oder importiert ..? In dem Fall kann es helfen, die Originaldatei zum Testen hochzuladen, als Anhang hier im Forum zum Beispiel. Wenn das nicht geht, per Mail an den Support.
Mein problemloses Linux-System: Debian Buster/Sid mit OpenBox/Rox Desktop.
Bild“People should go where they are not supposed to go, say what they are not supposed to say and stay, when they are told to leave.” (Howard Zinn)

dbet
Beiträge: 43
Registriert: 03.01.2014 15:41:51

Re: Datumsformat nur benutzerdefiniert

Beitrag von dbet » 05.01.2016 10:00:05

Gerne lade ich eine Datei hoch, in der ich meine Beobachtung beliebig oft wiederholden kann. Die Datei wurde nicht importiert, sondern neu erfasst.
Dateianhänge
Datum.xlsx
(6.55 KiB) 89-mal heruntergeladen

Kuno
SoftMaker Volunteers
SoftMaker Volunteers
Beiträge: 2269
Registriert: 02.03.2004 12:31:01
Wohnort: Osnabrück

Re: Datumsformat nur benutzerdefiniert

Beitrag von Kuno » 05.01.2016 10:45:46

Ich kann die Macke auch mit der hochgeladenen Datei nicht nachvollziehen. Wenn ich eine der Zellen mit den kommagetrennten Werten markiere und als Datum (kurz) formatiere, werden die kommata durch Punkte ersetzt. Wenn ich danach wieder mit der rechten Maustaste auf "Zelle" gehe, ist - wies sein soll - "Datum/Zeit" zu sehen...

PS: Wenn man ein Datum - wie vorgesehen - mit Punkten getrennt eingibt, passt das Format automatisch.
Warum eigentlich der Versuch mit den Kommata??
System
Core2Duo T9600 @ 2.80GHz 4Gb Ram - Dual Boot - Intel GM45 - Mesa 17.3.5-1
Debian Sid/Unstable Openbox - Linux 4.15.0-1-amd64
--------------------------------------------------------
Core2Duo P8700 @ 2.53GHz 4Gb Ram - Intel GM45 - Mesa13.0.6-1+b2
Debian Stretch Openbox - Linux 4.15.0-1-amd64

sven-l
SoftMaker Team
SoftMaker Team
Beiträge: 12253
Registriert: 09.04.2008 09:50:06
Wohnort: Nürnberg
Kontaktdaten:

Re: Datumsformat nur benutzerdefiniert

Beitrag von sven-l » 05.01.2016 11:23:56

@dbet: Verwenden Sie die aktuelle Revision 749?
Sven Leßmann
SoftMaker Software GmbH

dbet
Beiträge: 43
Registriert: 03.01.2014 15:41:51

Re: Datumsformat nur benutzerdefiniert

Beitrag von dbet » 06.01.2016 12:38:31

Kuno hat geschrieben:Ich kann die Macke auch mit der hochgeladenen Datei nicht nachvollziehen. Wenn ich eine der Zellen mit den kommagetrennten Werten markiere und als Datum (kurz) formatiere, werden die kommata durch Punkte ersetzt. Wenn ich danach wieder mit der rechten Maustaste auf "Zelle" gehe, ist - wies sein soll - "Datum/Zeit" zu sehen...

PS: Wenn man ein Datum - wie vorgesehen - mit Punkten getrennt eingibt, passt das Format automatisch.
Warum eigentlich der Versuch mit den Kommata??
Ich verwende keine Kommata, sondern Punkte. Hat das etwas mit den Ländereinstellungen zu tun?

dbet
Beiträge: 43
Registriert: 03.01.2014 15:41:51

Re: Datumsformat nur benutzerdefiniert

Beitrag von dbet » 06.01.2016 12:39:38

sven-l hat geschrieben:@dbet: Verwenden Sie die aktuelle Revision 749?
Ja, 749.
Ich beobachte das Problem sowohl unter Windows, als auch Linux und Android.

Kuno
SoftMaker Volunteers
SoftMaker Volunteers
Beiträge: 2269
Registriert: 02.03.2004 12:31:01
Wohnort: Osnabrück

Re: Datumsformat nur benutzerdefiniert

Beitrag von Kuno » 06.01.2016 13:21:29

dbet hat geschrieben:Ich verwende keine Kommata, sondern Punkte. Hat das etwas mit den Ländereinstellungen zu tun?
Wenn ich deine Beispieldatei aufmache, wird mir in Zelle A3 angezeigt "04,01,2016". In der Editierzeile steht zwar richtig 04.01.2016, als Zellenformat ist aber Benutzdefiniert "TT,MM,JJJJ" angegeben. Woher dieses Format nun kommt, kann ich mitnichten nachvollziehen.
Meine Ländereinstellung ist "Deutsch", Systemeinstellung "de_DE.UTF-8".
Hier mal eine bei mir frisch erstellte Datei:
DatumKuno.xlsx
(5.93 KiB) 71-mal heruntergeladen
System
Core2Duo T9600 @ 2.80GHz 4Gb Ram - Dual Boot - Intel GM45 - Mesa 17.3.5-1
Debian Sid/Unstable Openbox - Linux 4.15.0-1-amd64
--------------------------------------------------------
Core2Duo P8700 @ 2.53GHz 4Gb Ram - Intel GM45 - Mesa13.0.6-1+b2
Debian Stretch Openbox - Linux 4.15.0-1-amd64

sven-l
SoftMaker Team
SoftMaker Team
Beiträge: 12253
Registriert: 09.04.2008 09:50:06
Wohnort: Nürnberg
Kontaktdaten:

Re: Datumsformat nur benutzerdefiniert

Beitrag von sven-l » 07.01.2016 12:59:21

Kuno hat geschrieben:
dbet hat geschrieben:Ich verwende keine Kommata, sondern Punkte. Hat das etwas mit den Ländereinstellungen zu tun?
Wenn ich deine Beispieldatei aufmache, wird mir in Zelle A3 angezeigt "04,01,2016". In der Editierzeile steht zwar richtig 04.01.2016, als Zellenformat ist aber Benutzdefiniert "TT,MM,JJJJ" angegeben. Woher dieses Format nun kommt, kann ich mitnichten nachvollziehen.
Meine Ländereinstellung ist "Deutsch", Systemeinstellung "de_DE.UTF-8".
Hier mal eine bei mir frisch erstellte Datei:
DatumKuno.xlsx
Dasselbe auch bei mir. Mit welcher Ländereinstellung arbeiten Sie?
Sven Leßmann
SoftMaker Software GmbH

dbet
Beiträge: 43
Registriert: 03.01.2014 15:41:51

Re: Datumsformat nur benutzerdefiniert

Beitrag von dbet » 07.01.2016 14:45:46

Wenn ich Kunos Datei öffne, sehe ich das Datum mit Punkten, wie es sein sollte. Das Format ist Datum/Zeit 01.01.2016 und im selben Dialog steht unten bei Sprache Deutsch (Deutschland). Wenn ich nun in der gleichen Datei auf der nächsten freien Zeile das heutige Datum eingebe, wird mir 07.01.16 angezeigt. Beim Format steht nachher Benutzerdefiniert TT.MM.JJ. Will ich das Format auf Datum/Zeit ändern, wird mir im gleichen Dialog die Sprache Deutsch (Schweiz) vorgeschlagen. Aber selbst wenn ich auf Deutsch (Deutschland) ändere, ändert sich das Verhalten nicht, d.h. nach dem Klick auf OK und erneutem Laden des Format-Dialogs wir mir wieder Benutzerdefniert angezeigt.
Meine Spracheinstellung im Betriebssystem ist Deutsch Schweiz, de_CH.UTF-8. Im Planmaker habe ich unter Sprache Deutsch (Schweiz) angegeben, es verhält sich aber alles genau gleich, wenn ich hier auf Deutsch (Deutschland) ändere.

Bisher habe ich immer über den Dialog gesprochen, den ich via Format, Zelle aufrufe. Es gibt in der Format-Symbolleiste ja noch die Funktion Zahlenformat einstellen. Darüber funktioniert es auch bei mir. Ich wähle dann jeweils Datum kurz. Das Ergebnis ist dann im Format-Dialog Datum/Zeit 01.01.2016 Sprache Deutsch (Deutschland). Die Formatierung hält, bis ich wieder mit dem Formatdialog eine Änderung anbringe. Das habe ich gerade frisch herausgefunden.

sven-l
SoftMaker Team
SoftMaker Team
Beiträge: 12253
Registriert: 09.04.2008 09:50:06
Wohnort: Nürnberg
Kontaktdaten:

Re: Datumsformat nur benutzerdefiniert

Beitrag von sven-l » 07.01.2016 16:11:20

Anbei eine Antwort der Entwickler zu diesem Problem:
Die Datei ist mit einem falschen Datumstrenner geschrieben, korrekt wäre ein '/', es steht aber ein '.' drin. Der Datumstrenner des Systems ist also nicht der '.' sondern was anderes. Wurden die Datumsangaben mit dem '.' eingegeben oder mit etwas anderem? In der Log-Datei (zu erstellen unter Hilfe=>Über) stehen die aktuellen Trenner drin. Könnten Sie uns diese Datei bitte zusenden? Vielen Dank!
Sven Leßmann
SoftMaker Software GmbH

dbet
Beiträge: 43
Registriert: 03.01.2014 15:41:51

Re: Datumsformat nur benutzerdefiniert

Beitrag von dbet » 12.01.2016 21:16:08

Ich gebe ein Datum immer mit . ein, das ist in unseren Breitengraden ja normal so. Gerne lege ich die Datei sminfo.txt bei.
Dateianhänge
sminfo.txt
(55.92 KiB) 72-mal heruntergeladen

sven-l
SoftMaker Team
SoftMaker Team
Beiträge: 12253
Registriert: 09.04.2008 09:50:06
Wohnort: Nürnberg
Kontaktdaten:

Re: Datumsformat nur benutzerdefiniert

Beitrag von sven-l » 13.01.2016 15:05:15

Vielen Dank! Ich habe die Datei an die Entwickler weitergeleitet und werde mich wieder melden, sobald es eine Rückmeldung gibt.
Sven Leßmann
SoftMaker Software GmbH

sven-l
SoftMaker Team
SoftMaker Team
Beiträge: 12253
Registriert: 09.04.2008 09:50:06
Wohnort: Nürnberg
Kontaktdaten:

Re: Datumsformat nur benutzerdefiniert

Beitrag von sven-l » 05.02.2016 09:12:19

Der Fehler wurde behoben und sollte mit dem nächsten Service Pack nicht mehr vorkommen.
Sven Leßmann
SoftMaker Software GmbH

dbet
Beiträge: 43
Registriert: 03.01.2014 15:41:51

Re: Datumsformat nur benutzerdefiniert

Beitrag von dbet » 13.07.2016 12:53:57

Danke, ich habe das Problem nicht mehr auftreten gesehen.

Antworten

Zurück zu „PlanMaker 2016 für Linux“